Audio nicht synchron bei Export mit AAC

Forum rund um den Videoschnitt mit unserem Lieblingsprogramm.

Moderatoren: Indio, Frank Vogelskamp, danny, dr.f, Nico

daenjiel
Newbie
Beiträge: 5
Registriert: 10.06.2021, 10:19

Audio nicht synchron bei Export mit AAC

Beitrag von daenjiel » 11.06.2021, 10:20

Hallo liebe Community,
ich habe ein Problem, bei dem ihr mir hoffentlich helfen könnt:

Vor ein paar Wochen ist mir aufgefallen, dass der Ton aller meiner exportierten Videos um 1-2 Frames nicht mehr synchron zu der Videospur ist.

Mein Setup:
MBP 2015, aktuelle Versionen von macOS Big Sur, Final Cut und Compressor.

Mein Arbeitsablauf:
Ich importiere mein Quellvideo als mxf-File (Linear PCM, XDCAM HD422 1080i50 (50 Mb/s), 48 kHz, 8 Monokanäle), schneide ein 1-2 Minuten langes Video, füge Effekte und etwas Musik (ebenfalls 48 kHz) hinzu – in Final Cut wird alles korrekt angezeigt.

Aber dann exportiere ich mein Video als 1080p25 H.264 und AAC Audio (48 kHz) und am Ende kommt ein Video mit asynchronem Audio um einen Frame raus. Während das in Quicktime und VLC nicht so auffällt, kommt Facebook damit offenbar gar nicht klar und O-Töne sind komplett asynchron zur Videospur.

Wenn ich das exportierte Video in Final Cut auf die Zeitleiste des Schnitts lege, kann ich sehen, dass das der letzte Frame des exportierten Videos stumm ist. Es scheint so, dass Final Cut den Ton des ersten Frames des Videos abschneidet und den gesamten Ton um einen Frame nach vorne verschiebt und der letzte Frame einfach still ist. Wenn man die Timeline mit Audio der Schnittfassung und der exportierten Version gleichzeitig abspielt, hört man den einen Frame auch raus. Bei Frame-genauem Schnitt auf Musik ist es auch sichtbar/hörbar.

Ich habe verschiedene Einstellungen und Voreinstellungen in Final Cut und Compressor ausprobiert, aber jedes Mal, wenn ich den AAC-Codec beim Export verwende, hat das endgültige Video einen asynchronen Ton. Wenn ich das Video mit Linear PCM exportiere, funktioniert alles einwandfrei. Dabei ist es auch egal, ob das Quellmaterial AAC-Audio hat oder Linear PCM. Seltsamerweise verschiebt sich die Audio-Spur nicht, wenn nur ich die Audio-Spur als AAC ohne Video direkt aus Final Cut exportiere, die läuft synchron zum Schnitt in FCP.

Habe dasselbe Video mal mit Premiere Pro exportiert, da ist der Ton und in FCP unter den Schnitt gezogen, auch da ist der Ton nicht 100%ig synchron, aber nicht ansatzweise so schlimm wie in FCP.

Ich hoffe, dass jemand dafür eine Lösung hat, denn das war definitiv in alten Projekten nicht so, da läuft der Ton synchron zum Schnitt.

Benutzeravatar
danny
Final Cut Director
Beiträge: 9928
Registriert: 14.07.2004, 20:27
Firma: Freelancer
Kontaktdaten:

Re: Audio nicht synchron bei Export mit AAC

Beitrag von danny » 11.06.2021, 12:09

Hey Dan,
herzlich willkommen im Forum. Zunächst würde ich Dich bitten dein Profil komplett auszufüllen, wenn Du es nicht schon gemacht hat.

Nun zu Deiner Frage:
Ich würde zunächst erst einmal einen Export als Pro Res File machen und davon in Compressor ein H264 erzeugen. Das hat den Vorteil, dass Du im Pro Res-File immer erst einmal dein Audio-Sync checken kannst.

Das H264-Format ist ein GOP-Format und neigt dazu gerne mal out-of-sync zu sein. Vor allem, wenn Du die "üblichen Verdächtigen" an Plattformen verwendest wie etwa Youtube.

Was Du nämlich wissen musst, ist das Youtube im Zweifel gar nicht DEIN File verwendet, sondern dieses nur als Source-Clip zum Transcodieren in HD/SD verwendet wird. Dabei ergibt sich ja schon eine zweite Generation an komprimierten Daten.

Also versuch es erstmal über den Weg ein Pro Res zu exportieren.

LG

Danny

daenjiel
Newbie
Beiträge: 5
Registriert: 10.06.2021, 10:19

Re: Audio nicht synchron bei Export mit AAC

Beitrag von daenjiel » 11.06.2021, 13:56

Erst mal vielen Dank für die Antwort. Mein Profil (Hardware, Software, OS) ist eigentlich ausgefüllt.

Leider hilft der beschriebene Weg (Pro Res -> H264 in Compressor) nicht weiter, das hatte ich auch schon alles probiert, aber sobald AAC für Audio genutzt wird, tritt der oben beschriebene Fehler auf – in FCP, Compressor und auch, wie gerade gecheckt, in Handbreak.

Dass Online-Plattformen mein Video-File nicht direkt abspielen, ist mir schon klar, die Out-of-Sync-Probelmatic scheint sich durch das Wandeln der Plattformen jedoch zu verstärken.

Die vergangen Jahre hat das alles problemlos geklappt, bis ich jedoch vor ein paar Wochen während des Urlaubs von Mojave auf Big Sur geupgraded habe, weil viele Apps, u.a. FCP, unter Mojave keine Updates mehr bekamen, gefühlt tritt seitdem das Problem auf. Muss wohl mal am Wochenende Mojave auf einer externen SSD installieren.

Tritt das bei dir denn nciht auf, wenn du aus FCP direkt h264 mit AAC exportierst?

Traveller
Final Cut Director 10K+
Beiträge: 11679
Registriert: 05.06.2006, 10:50

Re: Audio nicht synchron bei Export mit AAC

Beitrag von Traveller » 11.06.2021, 22:10

Grundsätzlich: das Problem existiert nicht, mp4-Exporte sind definitiv synchron. Machen wir dauern und viel, für alles Mögliche wie auch Social Media.

Es stellt sich also die Frage, was du anders machst als andere. Interlaced ist Absicht (TV-Zulieferung)? Field Order stimmt?

Mal die Standardausgabe „Computer“ aus fcp genommen?

daenjiel
Newbie
Beiträge: 5
Registriert: 10.06.2021, 10:19

Re: Audio nicht synchron bei Export mit AAC

Beitrag von daenjiel » 13.06.2021, 21:53

Danke, sehe ich auch so, dass das eingentlich synchron sein muss, war vorher ja auch so…
Ja, Interlaced ist gewollt, weil TV-Material und Einstellungen passen, Problem ist auch nicht das BIld (das bleibt auf den Frame genau wie im Schnitt). Das Format des Quellmaterial ist dabei auch egal, auch wenn das Quellmaterial H264 und AAC codiert ist und ich es einfach mit den Standardexporteinstellungen von FCP als H264 und ACC exportiere, ist die Tonspur nicht mehr synchron.

Anscheinend liegt das Problem tierfer in macOS: Ich habe gerade Big Sur auf einer externen SSD installiert und dann mit FCP ein H264/AAC-Video mit den Standrdsettings als H264 und ACC exportiert – genau derselbe Fehler…

Traveller
Final Cut Director 10K+
Beiträge: 11679
Registriert: 05.06.2006, 10:50

Re: Audio nicht synchron bei Export mit AAC

Beitrag von Traveller » 14.06.2021, 18:50

Welches Ausgabe-Preset nimmst du denn genau?

Benutzeravatar
danny
Final Cut Director
Beiträge: 9928
Registriert: 14.07.2004, 20:27
Firma: Freelancer
Kontaktdaten:

Re: Audio nicht synchron bei Export mit AAC

Beitrag von danny » 14.06.2021, 23:46

daenjiel hat geschrieben:
11.06.2021, 13:56
Tritt das bei dir denn nciht auf, wenn du aus FCP direkt h264 mit AAC exportierst?
Nabend,
ich kann Dein Problem auch nicht nachvollziehen. Ich habe auf unterschiedlichen Rechnern Mojave und auch Big Sur drauf und auf beiden sind meine exporte sync und auch hier werden viele H264-Files erzeugt/transcodiert.

Aber Du hast mir auch meine Frage nicht eindeutig beantwortet: sind aus FCP exportierte Apple Pro-Res-Files sync?

Hast Du vielleicht irgendwelche Audio-Plugins in der direkten Core-Audio-Ausgabe drin (nicht in FCP) - es gibt ja solche speziellen Audio-Einmess-Tools, die sich in die Ausgabe klemmen und Latenzen erzeugen.

Dumbeldore
Final Cut Profi
Beiträge: 1906
Registriert: 05.04.2009, 12:21

Re: Audio nicht synchron bei Export mit AAC

Beitrag von Dumbeldore » 15.06.2021, 07:56

Moin,

will mich mit meiner bescheidenen Unkenntnis zwar nicht einmischen... ;-)

Aber könnte es am Ende evtl. mit einer Abhör-Hardware zu tun haben, die seit Big Sur von unterschiedlichen Apps unterschiedlich bedient wird?
Nur so ein Gedanke!

LG

daenjiel
Newbie
Beiträge: 5
Registriert: 10.06.2021, 10:19

Re: Audio nicht synchron bei Export mit AAC

Beitrag von daenjiel » 15.06.2021, 16:18

Traveller hat geschrieben:
14.06.2021, 18:50
Welches Ausgabe-Preset nimmst du denn genau?
Habe jahrelang ein eigenes verwendet, aber auch wenn ich einfach das Standrad-Preset von Apple benutze (was standardmäßig unter CMD+E als Originaldatei gespeichert ist) und dann unter Einstellungen den Video-Codec auf H264 umstelle, Audio wird dann ja automtisch mit AAC codiert, tritt das Problem auf. Habe auch die eine Reihe anderer Presets aus Compressor ausprobiert, bei jedem mit AAC-Audio habe ich das Problem.

Wie würdest du denn die Einstellungen wählen?
Mit denen hier hat bis vor wenigen Wochen immer als funktioniert:
Ohne Titel 3.jpg
danny hat geschrieben:
14.06.2021, 23:46
Aber Du hast mir auch meine Frage nicht eindeutig beantwortet: sind aus FCP exportierte Apple Pro-Res-Files sync?

Hast Du vielleicht irgendwelche Audio-Plugins in der direkten Core-Audio-Ausgabe drin (nicht in FCP) - es gibt ja solche speziellen Audio-Einmess-Tools, die sich in die Ausgabe klemmen und Latenzen erzeugen.
Pro-Res-Files sind synchron, solange ich nicht AAC als Audio-Codec nutze. Sobald der AAC-Codec ins Spiel kommt, ist die Audiospur der finalen Datei nicht mehr synchron zum Bild, sondern um einen Frame noch vorne verschoben. Audio-Plugins nutze ich nicht und war ja leider auch bei einem frisch aufgesetzten System, wo ich nur Final Cut installiert habe… Kann ich das CorAudio-Framewor irgendwie zurücksetzten bzw einsehen, ob da irgendwelche Erweiterungen drin hängen?
Dumbeldore hat geschrieben:
15.06.2021, 07:56
Aber könnte es am Ende evtl. mit einer Abhör-Hardware zu tun haben, die seit Big Sur von unterschiedlichen Apps unterschiedlich bedient wird?
Nur so ein Gedanke!
Nee, nutze nur ganz normale Klinken-Kopfhörer direkt am Mac.

Hier mal ein Vergleich zwischen Schnitt und darunter den exportierten Videos mit Premiere Pro und FCP. Die Videospur bleibt framegenau an ihrer Position, nur Audio ist jeweils anders:
Bildschirmfoto 2021-06-09 um 16.35.55.png
Bildschirmfoto 2021-06-09 um 16.35.55.png (113.26 KiB) 221 mal betrachtet

Traveller
Final Cut Director 10K+
Beiträge: 11679
Registriert: 05.06.2006, 10:50

Re: Audio nicht synchron bei Export mit AAC

Beitrag von Traveller » 16.06.2021, 05:52

Nimm direkt in fcp - ohne Compressor-Umweg - einfach mal „Apple Geräte 1080p“. Und NICHTS verstellen oder umstellen.
Ergibt ein m4v, das du einfach zu mp4 ändern kannst. Oder stell im Preset den Reiter auf „Computer“, dann wird‘s gleich ein mp4 mit etwas höherer Datenrate.

Immer noch asynchron?

Wenn ja, würde ich vielleicht mal den Rechner völlig neu aufsetzen. Weil dann irgend etwas grundlegend vergeigt sein muss.

daenjiel
Newbie
Beiträge: 5
Registriert: 10.06.2021, 10:19

Re: Audio nicht synchron bei Export mit AAC

Beitrag von daenjiel » 20.06.2021, 23:58

Traveller hat geschrieben:
16.06.2021, 05:52
Nimm direkt in fcp - ohne Compressor-Umweg - einfach mal „Apple Geräte 1080p“. Und NICHTS verstellen oder umstellen.
Ergibt ein m4v, das du einfach zu mp4 ändern kannst. Oder stell im Preset den Reiter auf „Computer“, dann wird‘s gleich ein mp4 mit etwas höherer Datenrate.

Immer noch asynchron?

Wenn ja, würde ich vielleicht mal den Rechner völlig neu aufsetzen. Weil dann irgend etwas grundlegend vergeigt sein muss.
Ja, ist – wie zu erwarten war – asynchron…
Habe auch schon (siehe meine Post oben) Big Sur auf einer externen Platte installiert und nur FCP (die Trial Version, um iCloud Setup zu umgehen) installiert, gleoches Problem… Irgendwas stimmt da wohl nicht in Kombination mit meiner MacBook-Generation, mal die Tage mit Mojave ausprobieren.

Antworten