Audio nicht synchron bei Export mit AAC

Forum rund um den Videoschnitt mit unserem Lieblingsprogramm.

Moderatoren: Indio, Frank Vogelskamp, danny, dr.f, Nico

daenjiel
Newbie
Beiträge: 2
Registriert: 10.06.2021, 10:19

Audio nicht synchron bei Export mit AAC

Beitrag von daenjiel » 11.06.2021, 10:20

Hallo liebe Community,
ich habe ein Problem, bei dem ihr mir hoffentlich helfen könnt:

Vor ein paar Wochen ist mir aufgefallen, dass der Ton aller meiner exportierten Videos um 1-2 Frames nicht mehr synchron zu der Videospur ist.

Mein Setup:
MBP 2015, aktuelle Versionen von macOS Big Sur, Final Cut und Compressor.

Mein Arbeitsablauf:
Ich importiere mein Quellvideo als mxf-File (Linear PCM, XDCAM HD422 1080i50 (50 Mb/s), 48 kHz, 8 Monokanäle), schneide ein 1-2 Minuten langes Video, füge Effekte und etwas Musik (ebenfalls 48 kHz) hinzu – in Final Cut wird alles korrekt angezeigt.

Aber dann exportiere ich mein Video als 1080p25 H.264 und AAC Audio (48 kHz) und am Ende kommt ein Video mit asynchronem Audio um einen Frame raus. Während das in Quicktime und VLC nicht so auffällt, kommt Facebook damit offenbar gar nicht klar und O-Töne sind komplett asynchron zur Videospur.

Wenn ich das exportierte Video in Final Cut auf die Zeitleiste des Schnitts lege, kann ich sehen, dass das der letzte Frame des exportierten Videos stumm ist. Es scheint so, dass Final Cut den Ton des ersten Frames des Videos abschneidet und den gesamten Ton um einen Frame nach vorne verschiebt und der letzte Frame einfach still ist. Wenn man die Timeline mit Audio der Schnittfassung und der exportierten Version gleichzeitig abspielt, hört man den einen Frame auch raus. Bei Frame-genauem Schnitt auf Musik ist es auch sichtbar/hörbar.

Ich habe verschiedene Einstellungen und Voreinstellungen in Final Cut und Compressor ausprobiert, aber jedes Mal, wenn ich den AAC-Codec beim Export verwende, hat das endgültige Video einen asynchronen Ton. Wenn ich das Video mit Linear PCM exportiere, funktioniert alles einwandfrei. Dabei ist es auch egal, ob das Quellmaterial AAC-Audio hat oder Linear PCM. Seltsamerweise verschiebt sich die Audio-Spur nicht, wenn nur ich die Audio-Spur als AAC ohne Video direkt aus Final Cut exportiere, die läuft synchron zum Schnitt in FCP.

Habe dasselbe Video mal mit Premiere Pro exportiert, da ist der Ton und in FCP unter den Schnitt gezogen, auch da ist der Ton nicht 100%ig synchron, aber nicht ansatzweise so schlimm wie in FCP.

Ich hoffe, dass jemand dafür eine Lösung hat, denn das war definitiv in alten Projekten nicht so, da läuft der Ton synchron zum Schnitt.

Benutzeravatar
danny
Final Cut Director
Beiträge: 9926
Registriert: 14.07.2004, 20:27
Firma: Freelancer
Kontaktdaten:

Re: Audio nicht synchron bei Export mit AAC

Beitrag von danny » 11.06.2021, 12:09

Hey Dan,
herzlich willkommen im Forum. Zunächst würde ich Dich bitten dein Profil komplett auszufüllen, wenn Du es nicht schon gemacht hat.

Nun zu Deiner Frage:
Ich würde zunächst erst einmal einen Export als Pro Res File machen und davon in Compressor ein H264 erzeugen. Das hat den Vorteil, dass Du im Pro Res-File immer erst einmal dein Audio-Sync checken kannst.

Das H264-Format ist ein GOP-Format und neigt dazu gerne mal out-of-sync zu sein. Vor allem, wenn Du die "üblichen Verdächtigen" an Plattformen verwendest wie etwa Youtube.

Was Du nämlich wissen musst, ist das Youtube im Zweifel gar nicht DEIN File verwendet, sondern dieses nur als Source-Clip zum Transcodieren in HD/SD verwendet wird. Dabei ergibt sich ja schon eine zweite Generation an komprimierten Daten.

Also versuch es erstmal über den Weg ein Pro Res zu exportieren.

LG

Danny

daenjiel
Newbie
Beiträge: 2
Registriert: 10.06.2021, 10:19

Re: Audio nicht synchron bei Export mit AAC

Beitrag von daenjiel » 11.06.2021, 13:56

Erst mal vielen Dank für die Antwort. Mein Profil (Hardware, Software, OS) ist eigentlich ausgefüllt.

Leider hilft der beschriebene Weg (Pro Res -> H264 in Compressor) nicht weiter, das hatte ich auch schon alles probiert, aber sobald AAC für Audio genutzt wird, tritt der oben beschriebene Fehler auf – in FCP, Compressor und auch, wie gerade gecheckt, in Handbreak.

Dass Online-Plattformen mein Video-File nicht direkt abspielen, ist mir schon klar, die Out-of-Sync-Probelmatic scheint sich durch das Wandeln der Plattformen jedoch zu verstärken.

Die vergangen Jahre hat das alles problemlos geklappt, bis ich jedoch vor ein paar Wochen während des Urlaubs von Mojave auf Big Sur geupgraded habe, weil viele Apps, u.a. FCP, unter Mojave keine Updates mehr bekamen, gefühlt tritt seitdem das Problem auf. Muss wohl mal am Wochenende Mojave auf einer externen SSD installieren.

Tritt das bei dir denn nciht auf, wenn du aus FCP direkt h264 mit AAC exportierst?

Traveller
Final Cut Director 10K+
Beiträge: 11657
Registriert: 05.06.2006, 10:50

Re: Audio nicht synchron bei Export mit AAC

Beitrag von Traveller » 11.06.2021, 22:10

Grundsätzlich: das Problem existiert nicht, mp4-Exporte sind definitiv synchron. Machen wir dauern und viel, für alles Mögliche wie auch Social Media.

Es stellt sich also die Frage, was du anders machst als andere. Interlaced ist Absicht (TV-Zulieferung)? Field Order stimmt?

Mal die Standardausgabe „Computer“ aus fcp genommen?

Antworten